Cannot install lsphp71-imagick: unmet dependencies

Posted by

I have an Ubuntu 18.04 LTS instance running on Amazon Lightsail and I have trouble installing lsphp71-imagick.

sudo apt install lsphp71-imagick

返回下面信息

The following packages have unmet dependencies:
lsphp74-imagick : 
Depends: libmagickcore-6.q16-3 (>= 8:6.9.6.8) but it is not installable               
Depends: libmagickwand-6.q16-3 (>= 8:6.9.6.8) but it is not installable
Recommends: ttf-dejavu-core but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

解决办法:

自动安装存储库

wget -O - http://rpms.litespeedtech.com/debian/enable_lst_debian_repo.sh | bash

手动修复

grep -Ri litespeedtech /etc/apt/*

安装 GPG 密钥和源

wget -qO - https://rpms.litespeedtech.com/debian/lst_repo.gpg | sudo apt-key add -
sudo echo "deb http://rpms.litespeedtech.com/debian/ focal main" > /etc/apt/sources.list.d/openlitespeed.list

然后运行apt-get update,它应该消失了

ubuntu